0

Is it mandatory to have drivers to connect Incorta to cassandra DB

Hi Team, 

I am trying to connect to Cassandra DB using Incorta. I am getting the attached error. Can you please help me on the same? 

I have gone through the article https://community.incorta.com/t/y7jwvd/how-to-connect-to-cassandra-3-11
We currently do not own the license for the cassandra drivers which you have mentioned. Is there any other work around? 

Is it mandatory to have the drivers copied to incorta library to connect to incorta with cassandra DB?

If yes, then could you please let us know the drivers and their versions to be used for "Incorta Version: Rel 3.5.1" so we can purchase the same?

Thanks in advance. 

Sowmya

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Cassandra out of the box connector is available starting at incorta release 3.1.9 provided that Simba driver is purchased and added by your side to <incorta_home>/server/lib.

    You may downloaded the Simba driver from 'https://www.simba.com/drivers/cassandra-odbc-jdbc/' and copy the below jar files to <incorta_home>/server/lib: 

            cassandra-driver-core-3.1.1.jar
            CassandraJDBC42.jar
           cassandra-driver-extras-3.1.1.jar
           cassandra-driver-mapping-3.1.1.jar

    Reply Like
Like Follow
  • 2 mths agoLast active
  • 1Replies
  • 53Views
  • 2 Following

Welcome!

Welcome to Incorta's user community! Whether you are already an Incorta customer, or interested in becoming one, this is your place to come together and discuss the software, register for webinars, learn about events, learn about new product releases and get support from the community.