0

Incorta Data Pull to MS SQL

While trying to run Incorta query in MS SQL, getting following error OLE DB provider 'MSDASQL' for linked server 'incorta' returned data that does not match expected data length for column '[MSDASQL].colName'. The (maximum) expected data length is 8000, while the returned data length is 14258. Can anyone plz help if there is way to increase the data pull to 14258.

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Can you send the data definition for the table from DB

    Like
      • Shankar S
      • Cisco
      • Shankar_S
      • 6 mths ago
      • Reported - view

      Ahmed Ezz col1 nvarchar(4000),col2 nvarchar(max),col3 nvarchar(max) Here col2 is having more than 8000 data length hence erroring out, commenting out this col resolves the issue. 

      Like
  • I have seen this before when trying to pull fields of type TEXT from a Postgres table into SQL Server. My solution was to:

    1) Add the parameter: TextAsLongVarchar=1 to the connection string

    2) Add the parameter: MaxLongVarcharSize = XXX to the connection string. Set XXX to an appropriate size

    3) Bring the Postgres TEXT field into a field of SQL type VARCHAR(MAX)

    Not sure if this is your situation but maybe will point you in the right direction.

    Like 2
  • Steve Ware Thanks. Is there an option to configure in Microsoft SQL, was not able find these in Linked Server Config

    Like
Like Follow
  • 6 mths agoLast active
  • 4Replies
  • 31Views
  • 3 Following

Product Announcement

A new community experience is coming! If you would like to have beta access to provide feedback, please contact us at community@incorta.com.