vague error message

I have a materialized view in Python and when I try to load returns this error:

com.incorta.api.exceptions.DataException: INC_03070101: Failed to load data from [spark://xxx.xxxxx.com:7077] with properties [[error, Unexpected error from the driver: Materialized View job [aaa.DEMANDS] has been terminated.
at com.incorta.loader.transformer.SparkTransformer.execute(SparkTransformer.java:108)
at com.incorta.loader.transformer.SparkTransformer.execute(SparkTransformer.java:51)
at com.incorta.loader.transformer.TransformerJob.transform(TransformerJob.java:92)
at com.incorta.loader.transformer.TransformerJob.transform(TransformerJob.java:63)
at com.incorta.loader.etl.TransformationPhase.transformTable(TransformationPhase.java:147)
at com.incorta.loader.etl.TransformationPhase.access$000(TransformationPhase.java:33)
at com.incorta.loader.etl.TransformationPhase$1.doAction(TransformationPhase.java:89)
at com.incorta.util.ConcurrentService$3.call(ConcurrentService.java:154)
at com.incorta.util.ConcurrentService$3.call(ConcurrentService.java:142)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at com.incorta.util.ConcurrentService$Job.execute(ConcurrentService.java:321)
at com.incorta.loader.etl.TransformationPhase.executePhase(TransformationPhase.java:96)
at com.incorta.loader.etl.ETLJob.transform(ETLJob.java:267)
at com.incorta.loader.etl.ETLJob.execute(ETLJob.java:102)
at com.incorta.loader.LoaderImpl.doLoadData(LoaderImpl.java:278)
at com.incorta.loader.LoaderImpl$1.call(LoaderImpl.java:209)
at com.incorta.loader.LoaderImpl$1.call(LoaderImpl.java:206)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

This is an on-premise server running 4.8.5. 

Where can I find more detail to help fix this?



4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Chris - Seems like some spark config issue, can you pls log a support ticket? I would also recommend that you upgrade to a 4.9.13  release.

  • It seems that you may have a Spark configuration issue.  Please try the following:

    1. Go to a the spark web UI and see the spark cluster is up and running
    2. You should be able to see a page like the screen shot
    3. If it is running, please test if it is accessible from Incorta.   First, check 'ping xxx.xxxxx.com'.
    4. We can also try to run it from a spark client
    5. If the Spark web UI page is not available, please check if the spark process is running from the backend
    6. Restart the spark master and spark worker (Slave) by running the StartSpark.sh from <Incorta Home>/IncortaNode

    Has your MV ever run before?  Or this is the first MV?

    Is this the only MV that is not running?  Or all MVs are getting the same error?

    Like 1
  • Amit, I logged a support ticket.

    Dylan:  other MV's are running fine.  This particular MV worked fine with less complex code, but with further development is now failing.

    • Chris Chen this is usually a memory/resources issue. If you haven't already, try substantially increasing the memory allocated to your executor and bump up the assigned cores as well. If using dynamic allocation, you may be hitting the ceiling on your Spark cluster's resources. Support will be able to assist with root cause here.

      Like 1
Like1 Follow
  • 6 days agoLast active
  • 4Replies
  • 14Views
  • 4 Following

Product Announcement

Incorta 5 is now Generally Available