Connect Postgres  SQL

Hi Team,

i am trying to connect Postgres  SQL from incorta . while try to connect my incorta server getting below error. Please advice on this.


  • Server: <name or IP of the Incorta server>
  • Port: <Incorta SQL interface port, default=5436>
  • Database: <name of Incorta tenant, e.g. demo>
  • Username: <user name you use to login to Incorta via web browser>
  • Password: <password you use to login to Incorta via web browser>



Error: [java.lang.Exception: Failed to get metadata due to: java.lang.UnsupportedOperationException: . Spark
fallback: No schema for table: pg_database and no default schema set: . Spark fallback: No schema for table:
pg_database and no default schema set



Delli M

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi Delli -- This is probably because Incorta expects Spark to be running alongside Incorta, but it isn't.  Thus, you should try one of two things:  1) Start Spark in your Incorta installation or 2) in the Incorta Admin UI, turn off the "Enable SQL App" setting so that Incorta doesn't attempt to integrate with SparkSQL for incoming queries to the Incorta SQL interface (see screenshot).  

    We typically recommend #1 as this will provide you with the largest amount of SQL query syntax support.  For simple SQL queries, #2 will suffice.

  • Also, what version of Incorta are you running?

  • It looks like we're not able to handle a PostgreSQL metadata query. I assume you're using Tableau since you mentioned the link to connecting Tableau to Incorta article.

    What is the version of the JDBC driver your're using with Tableau ?

  • Hi Dan/Muhammad,

    Thanks for the reply!

    Muhammad Gelbana  we are using "dbForge Studio Express for PostgreSQL" tool to connect the Incorta PostgreSQL.

    Dan Brock Yes , we enabled the mentioned options in Admin UI but still no luck :( and application Version: Rel3.6.1 


    Delli M

  • Delli ,

    Can you attempt to connect with Tableau or PowerBI or dbVisualizer?  I don't know if we've ever tried the tool you mention -- it may be expecting metadata about the Postgres database that our SQL interface isn't built to return.


Like Follow
  • Status Answered
  • 2 yrs agoLast active
  • 5Replies
  • 364Views
  • 3 Following

Product Announcement

A new community experience is coming! If you would like to have beta access to provide feedback, please contact us at community@incorta.com.