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amr_elwadiah
Cosmonaut

Symptoms

  • When logging into Incorta, it shows that the license has expired, although it is not
  • On the CMC, the analytics service shows a warning message that the license is invalid. Restarting the service does not help.
  • Deploying a new license has no effect.
  • Applies to Incorta on-premises, starting from release 5.2.3

Untitled1.jpgUntitled2.jpg

Diagnosis

This is caused by a missing file related to the license, and it is probably missing in these two places:

  • <incorta_home>/IncortaNode/services/<analytics_guid>/incorta/TIME_CHECK
  • <incorta_home>/cmc/license_data/TIME_CHECK

The noticed behavior that occurred prior to the absence of these files, is that the disk space was full.

Solution

Create an empty file with the same name TIME_CHECK on the same paths above and restart the analytics and CMC.

Comments
AhmedM
Employee
Employee

Thank you for this article, it helped me solve a customer problem 👍

Something I noticed is that the full disk space (which was the root cause) would also cause Zookeeper to go down, so It's worth it to check on Zookeeper and start it if necessary.

So, freeing some disk space is also important for the solution to work.

A restart for the analytics was required in my case, but I didn't need to restart the CMC.

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Version history
Last update:
‎01-18-2023 09:10 AM
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