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on 02-18-2025 09:35 AM
Symptoms
You have a scheduled email report that didn't get sent out at the scheduled time on for Incorta version 2024.1.4.
Diagnosis
in the Incorta Analytics logs, you see the below error :
(in this example, the scheduled email report was supposed to be sent out at 6:00, and you can see that it was not sent out as it timed out at 120,000 milliseconds)
ERROR: [06:02:10.512] [6301] [Send HTML Dashboard] executeSendHtmlDashboard with jobInfo: [jobId = 110, jobName = Daily Flash Report, ownerId = 155, jobType = SendDashboard] [com.incorta.server.scheduler.SendDashboardAction.executeSendHtmlDashboard]
ERROR: [06:02:10.512] [6301] [Send HTML Dashboard] com.incorta.api.exceptions.InternalServerException: INC_05121201: Failed to start the headless browser [com.incorta.server.scheduler.SendDashboardAction.executeSendHtmlDashboard]
ERROR: [06:02:10.512] [6301] [Send HTML Dashboard] at com.incorta.viewer.DashboardRenderer.render(DashboardRenderer.java:301)
............
ERROR: [06:02:10.512] [6301] [Send HTML Dashboard] Caused by: com.microsoft.playwright.TimeoutError: Timeout 120000ms exceeded [com.incorta.server.scheduler.SendDashboardAction.executeSendHtmlDashboard]
ERROR: [06:02:10.513] [6301] [Send HTML Dashboard] at com.microsoft.playwright.impl.WaitableTimeout.get(WaitableTimeout.java:41)
ERROR: [06:02:10.513] [6301] [Send HTML Dashboard] at com.microsoft.playwright.impl.WaitableRace.get(WaitableRace.java:44)
ERROR: [06:02:10.513] [6301] [Send HTML Dashboard] at com.microsoft.playwright.impl.ChannelOwner.runUntil(ChannelOwner.java:103)
ERROR: [06:02:10.513] [6301] [Send HTML Dashboard] at com.microsoft.playwright.impl.FrameImpl.waitForLoadStateImpl(FrameImpl.java:837)
ERROR: [06:02:10.513] [6301] [Send HTML Dashboard] at com.microsoft.playwright.impl.FrameImpl.waitForLoadStateImpl(FrameImpl.java:822)
........
Solution
- First, try to send it manually to ensure the report can be sent successfully. Ensure there are no errors in the dashboard.
- Check if there are a lot of scheduled email reports at that specific time to see if there is a high load at that exact time; if there are a couple of email reports scheduled at that time, you can try and postpone this job and see if it was sent fine.
- If the issue remains, you will need to increase the timeout following the below steps :
Go to the CMC > Cluster configurations > Server configurations, increase the "Headless Rendering Timeout (in milliseconds)" in the email from 120,000 to 480,000
Starting 2024.7.4, new fixes regarding timeouts and ensuring reliability, as well as a flag to enable more playwright traces & logs for better observability
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